domingo, 31 de maio de 2009

Como acessar o Internet Banking da Caixa Econômica no Firefox 3.5

Atualização da solução para o Firefox 15 até o atual 19.0.2 (25/março/2013)

Solução para outras versões antigas do firefox logo abaixo
---------------------------------------------------------------------------

atualização (12/01/2009):
 As dicas abaixo se aplicam ao firefox 3.6. Se quiser, eu criei uma versão simplificada para acessar a Caixa com o Firefox (tanto windows como Linux), clique aqui.


atualização (22/11/2009):
  Acessar a Caixa Econômica pelo Firefox é muito mais interativo e rápido que pelo Internet Explorer. Voce pode instalar o certificado raiz pelo link CA complementar do MozDev.

  Caso queira saber mais sobre certificado, caixa e firefox, veja as dicas abaixo.



atualização (28/09/09):
 Com o firefox 3.5 final (windows version), rodando tanto no windows como no wine no linux, e a última atualização do módulo de segurança pela própria caixa econômica, basta colocar no seu firefox o link https://imagem.caixa.gov.br/ aceitar o certificado (veja o passo 1, caso tenha dúvidas) depois disso basta acessar o site do Internet Banking Caixa normalmente. Portanto fica como dica de como fazer modificações em modulos, caso queira.
 O problema do certificado acontece porque o Firefox não vem com a CA da CAIXA PF como entidade certificadora válida.
 Pode-se instalar, também, o certificado geral em CA ITI e siga os passos para o Firefox.

Qualquer dúvida me postem!

Atualmente para acessar o banco da Caixa Econômica Federal no Linux,um Ubuntu Jaunty Jackalope (9.04), eu utilizo o wine 1.1.22 e o Firefox 3.5b4. (como instalar o wine? clique aqui.)

Um dos problemas que enfrentei foi o módulo de segurança da Caixa, que tem como restrição a versão do Firefox 3.0 para funcionar. A versão beta do Firefox 3.1 até aceitava módulos feitos para 3.0, porém no beta 3.5b4 não funcionou mais.

Então segue uma solução para o problema, com dicas passo à passo! Ao invés de eu disponibilizar o módulo da Caixa modificado, eu ensino a modificar. Acho que é altamente inseguro e não recomendo que baixem caso disponibilizem uma modificação pronta! Nunca se sabe os trojans que se colocam...

Só atenção! No Linux eu utilizo o Firefox beta versão para Windows funcionando sobre o Wine , o módulo da caixa não funciona no Firefox para Linux. A caixa econômica não disponibiliza o módulo nativo para o firefox do linux. Fiz isso baixando o instalador do firefox versão windows e executando com o wine. Funciona direitinho. (como rodar o firefox com wine no linux) (o que é o wine?)

Seguem os passos para acessar o site:


1) entre no site da caixa, um atalho para isso é o https://internetbanking.caixa.gov.br/:
- Será pedido para aceitar o certificado, pode clicar no "entendo os riscos" , depois no botão "Adicionar exceção...", e na janela "Adicionar exceção de segurança" clique em "Verificar certificado" e, na parte inferior dessa tela, no botão "Confirmar exceção de segurança".
Essa tela de suspeita de segurança acontece pois o firefox não contém os certificados emitidos pela Caixa, por não conter o certificado raiz emissor para essa instituição. Portanto não abordarei aqui como fazer o registro geral desses certificados, apenas a parte prática.
E reforçando: A página do internet banking da Caixa vem diretamente da página http://www.caixa.gov.br, portanto caso se sinta mais confortável começando pela página inicial, sinta-se à vontade.

2) confirmando o certificado acima, você entrará normalmente na tela de acesso principal do Internet Banking.
Acesse normalmente colocando seu usuário e clicando em "confirmar".




3) haverá a página reclamando que você não possui o modulo de segurança, clique em "concordo"





4) o Firefox reclamará que o site da caixa não esta na lista de permissão para instalar módulos. Basta clicar em "permitir" na barra amarela no topo.




5) aqui temos mais um problema com certificado,pois se tentar instalar diretamente, ocorrerá um erro para baixar.
Esse erro ocorre porque o modulo xpi vem de outro site de segurança. Observe o https no caminho do módulo.
Portanto o que faremos é copiar o link para depois colar diretamente no navegador.


6) ao colocar no navegador o link copiado, siga os mesmos passos do item "1)", pois nesse momento você registrará um novo certificado. Depois do certificado aceito, ele abrirá uma tela para abrir ou salvar, então escolha salvar em algum lugar que você consiga encontrar depois, no caso eu gravei em z:\home\leonardo\Downloads\ (lembre-se, que apesar de eu estar usando linux, o firefox esta instalando sobre o wine, achando que esta no windows)

7) agora faça o seguinte siga os passos da tela ao lado, onde criamos uma pasta auxiliar, descompactamos os arquivos do xpi, editamos o install.rdf e recompactamos novamente o arquivo.
Voltando à edição do arquivo, onde usei o vi install.rdf (se preferir use outro editor) modifique a linha "maxVersion", mudando de "3.0+" para "3.5+", depois da edição basta continuar compactando



8) abra o arquivo GbMzhCef2.xpi , que foi recompactado no novo nome como foi explicado acima, pelo navegador firefox, ele pedirá
para instalar o modulo, clique normalmente em "instalar agora".





9) pode reiniciar o firefox e entrar normalmente no site do internet banking que o módulo funcionará.
Postar um comentário